What’s Vulnerable › Vulnerabilities
CVE-2024-39275: Advantech ADAM-5630 Use of Persistent Cookies Containing Sensitive Information
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-539
Description
Cookies of authenticated Advantech ADAM-5630 users remain as active valid cookies when a session is closed. Forging requests with a legitimate cookie, even if the session was terminated, allows an unauthorized attacker to act with the same level of privileges of the legitimate user.
Affected products
- Advantech ADAM-5630: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: Advantech ADAM-5630 2.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39275 or the next vulnerability affects your stack