What’s Vulnerable › Vulnerabilities
CVE-2024-39303: Weblate vulnerabler to improper sanitization of project backups
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-73
Description
Weblate is a web based localization tool. Prior to version 5.6.2, Weblate didn't correctly validate filenames when restoring project backup. It may be possible to gain unauthorized access to files on the server using a crafted ZIP file. This issue has been addressed in Weblate 5.6.2. As a workaround, do not allow untrusted users to create projects.
Affected products
- WeblateOrg weblate: from 4.14 before 5.6.2 — fixed in 5.6.2
How to fix
Upgrade to a fixed version: WeblateOrg weblate 5.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/commit/b6a7eace155fa0feaf01b4ac36165a9c5e63bfdd
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-jfgp-674x-6q4p
- https://github.com/WeblateOrg/weblate/commit/b6a7eace155fa0feaf01b4ac36165a9c5e63bfdd
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-jfgp-674x-6q4p
Get alerted when CVE-2024-39303 or the next vulnerability affects your stack