What’s Vulnerable › Vulnerabilities
CVE-2024-39304: ChurchCRM SQL Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-26 · updated 2026-06-17
- Weakness: CWE-89
Description
ChurchCRM is an open-source church management system. Versions of the application prior to 5.9.2 are vulnerable to an authenticated SQL injection due to an improper sanitization of user input. Authentication is required, but no elevated privileges are necessary. This allows attackers to inject SQL statements directly into the database query due to inadequate sanitization of the EID parameter in in a GET request to `/GetText.php`. Version 5.9.2 patches the issue.
Affected products
- ChurchCRM CRM: before 5.9.2 — fixed in 5.9.2
How to fix
Upgrade to a fixed version: ChurchCRM CRM 5.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/ChurchCRM/CRM/commit/e3bd7bfbf33f01148df0ef1acdb0cf2c2b878b08
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-2rh6-gr3h-83j9
- https://github.com/ChurchCRM/CRM/commit/e3bd7bfbf33f01148df0ef1acdb0cf2c2b878b08
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-2rh6-gr3h-83j9
Get alerted when CVE-2024-39304 or the next vulnerability affects your stack