What’s Vulnerable › Vulnerabilities
CVE-2024-39308: RailsAdmin Cross-site Scripting vulnerability in the list view
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-79
Description
RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).
Affected products
- https://github.com/sferik rails_admin ruby gem: before 2.3.0; from 3.0.0 before 3.1.3 — fixed in 2.3.0, 3.1.3
How to fix
Upgrade to a fixed version: https://github.com/sferik rails_admin ruby gem 2.3.0, 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/railsadminteam/rails_admin/commit/b5a287d82e2cbd1737a1a01e11ede2911cce7fef
- https://github.com/railsadminteam/rails_admin/commit/d84b39884059c4ed50197cec8522cca029a17673
- https://github.com/railsadminteam/rails_admin/issues/3686
- https://github.com/railsadminteam/rails_admin/security/advisories/GHSA-8qgm-g2vv-vwvc
- https://rubygems.org/gems/rails_admin/versions/2.3.0
- https://rubygems.org/gems/rails_admin/versions/3.1.3
- https://github.com/railsadminteam/rails_admin/commit/b5a287d82e2cbd1737a1a01e11ede2911cce7fef
- https://github.com/railsadminteam/rails_admin/commit/d84b39884059c4ed50197cec8522cca029a17673
- https://github.com/railsadminteam/rails_admin/issues/3686
- https://github.com/railsadminteam/rails_admin/security/advisories/GHSA-8qgm-g2vv-vwvc
- https://rubygems.org/gems/rails_admin/versions/2.3.0
- https://rubygems.org/gems/rails_admin/versions/3.1.3
Get alerted when CVE-2024-39308 or the next vulnerability affects your stack