What’s Vulnerable › Vulnerabilities
CVE-2024-3931: Totara LMS User Selector check.php cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Totara LMS up to 18.7. It has been rated as problematic. Affected by this issue is some unknown functionality of the file admin/roles/check.php of the component User Selector. The manipulation of the argument ID Number leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 13.46, 14.38, 15.33, 16.27, 17.21 and 18.8 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- Totara: from 13.0 before 13.46; from 14.0 before 14.38; from 15.0 before 15.33; from 16.0 before 16.27; from 17.0 before 17.21; from 18.0 before 18.8 — fixed in 13.46, 14.38, 15.33, 16.27, 17.21, 18.8
How to fix
Upgrade to a fixed version: Totara 13.46, 14.38, 15.33, 16.27. Check the vendor advisory for mitigations.
References
- https://totara.community/mod/forum/discuss.php?d=27644
- https://vuldb.com/?ctiid.261368
- https://vuldb.com/?id.261368
- https://vuldb.com/?ctiid.261368
- https://vuldb.com/?id.261368
Get alerted when CVE-2024-3931 or the next vulnerability affects your stack