What’s Vulnerable › Vulnerabilities
CVE-2024-39311: Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Publify is a self hosted Web publishing platform on Rails. Prior to version 10.0.1 of Publify, corresponding to versions prior to 10.0.2 of the `publify_core` rubygem, publisher on a `publify` application is able to perform a cross-site scripting (XSS) attack on an administrator using the redirect functionality. The exploitation of this XSS vulnerability requires the administrator to click a malicious link. An attack could attempt to hide their payload by using HTML, or other encodings, as to not make it obvious to an administrator that this is a malicious link. A publisher may attempt to use this vulnerability to escalate their privileges and become an administrator. Version 10.0.1 of Publify and version 10.0.2 of the `publify_core` rubygem fix the issue.
Affected products
- Publify: before 10.0.1 — fixed in 10.0.1
- Publify Core: before 10.0.2 — fixed in 10.0.2
How to fix
Upgrade to a fixed version: Publify 10.0.1; Publify Core 10.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q
- https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q
Get alerted when CVE-2024-39311 or the next vulnerability affects your stack