What’s Vulnerable › Vulnerabilities
CVE-2024-39320: Discourse allows iframe injection though default site setting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-74
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
Affected products
- discourse: before 3.2.5; 3.3.0-beta1, 3.3.0-beta2, 3.3.0-beta3, 3.3.0-beta4 — fixed in 3.2.5
How to fix
Upgrade to a fixed version: discourse 3.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e
- https://github.com/discourse/discourse/security/advisories/GHSA-4p82-xh38-gq4p
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e
- https://github.com/discourse/discourse/security/advisories/GHSA-4p82-xh38-gq4p
Get alerted when CVE-2024-39320 or the next vulnerability affects your stack