What’s Vulnerable › Vulnerabilities
CVE-2024-39321: Traefik vulnerable to bypassing IP allow-lists via HTTP/3 early data requests in QUIC 0-RTT handshakes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-05 · updated 2026-06-17
- Weakness: CWE-639
Description
Traefik is an HTTP reverse proxy and load balancer. Versions prior to 2.11.6, 3.0.4, and 3.1.0-rc3 have a vulnerability that allows bypassing IP allow-lists via HTTP/3 early data requests in QUIC 0-RTT handshakes sent with spoofed IP addresses. Versions 2.11.6, 3.0.4, and 3.1.0-rc3 contain a patch for this issue. No known workarounds are available.
Affected products
- Traefik: before 2.11.6; from 3.0.0 before 3.0.4; 3.1.0, 3.1.0-rc1, 3.1.0-rc2 — fixed in 2.11.6, 3.0.4
How to fix
Upgrade to a fixed version: Traefik 2.11.6, 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/traefik/traefik/releases/tag/v2.11.6
- https://github.com/traefik/traefik/releases/tag/v3.0.4
- https://github.com/traefik/traefik/releases/tag/v3.1.0-rc3
- https://github.com/traefik/traefik/security/advisories/GHSA-gxrv-wf35-62w9
- https://github.com/traefik/traefik/releases/tag/v2.11.6
- https://github.com/traefik/traefik/releases/tag/v3.0.4
- https://github.com/traefik/traefik/releases/tag/v3.1.0-rc3
- https://github.com/traefik/traefik/security/advisories/GHSA-gxrv-wf35-62w9
Get alerted when CVE-2024-39321 or the next vulnerability affects your stack