What’s Vulnerable › Vulnerabilities

CVE-2024-39324: aimeos/ai-admin-graphql improper access control vulnerability allows editors to manage own services

Description

aimeos/ai-admin-graphql is the Aimeos GraphQL API admin interface. Starting in version 2022.04.1 and prior to versions 2022.10.10, 2023.10.6, and 2024.4.2, improper access control allows a editors to manage own services via GraphQL API which isn't allowed in the JQAdm front end. Versions 2022.10.10, 2023.10.6, and 2024.4.2 contain a patch for the issue.

Affected products

How to fix

Upgrade to a fixed version: aimeos ai-admin-graphql 2022.10.10, 2023.10.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-39324 or the next vulnerability affects your stack