What’s Vulnerable › Vulnerabilities
CVE-2024-39338
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-918
Description
axios 1.7.2 allows SSRF via unexpected behavior where requests for path relative URLs get processed as protocol relative URLs.
Affected products
- axios: from 1.3.2 before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: axios 1.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/releases
- https://jeffhacks.com/advisories/2024/06/24/CVE-2024-39338.html
Get alerted when CVE-2024-39338 or the next vulnerability affects your stack