What’s Vulnerable › Vulnerabilities

CVE-2024-39361: Creating posts with user-defined IDs permitted in CreatePost API

Description

Mattermost versions 9.8.0, 9.7.x <= 9.7.4, 9.6.x <= 9.6.2 and 9.5.x <= 9.5.5 fail to prevent users from specifying a RemoteId for their posts which allows an attacker to specify both a remoteId and the post ID, resulting in creating a post with a user-defined post ID. This can cause some broken functionality in the channel or thread with user-defined posts

Affected products

How to fix

Upgrade to a fixed version: Mattermost App Framework 9.5.6, 9.6.3, 9.7.4, 9.8.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-39361 or the next vulnerability affects your stack