What’s Vulnerable › Vulnerabilities
CVE-2024-39377: Media Encoder | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-787
Description
Media Encoder versions 24.5, 23.6.8 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Media Encoder: before 23.6.9; from 24.0 before 24.6 — fixed in 23.6.9, 24.6
How to fix
Upgrade to a fixed version: Adobe Media Encoder 23.6.9, 24.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39377 or the next vulnerability affects your stack