What’s Vulnerable › Vulnerabilities
CVE-2024-39380: After Effects | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-122
Description
After Effects versions 23.6.6, 24.5 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 23.6.9; from 24.0 before 24.6 — fixed in 23.6.9, 24.6
How to fix
Upgrade to a fixed version: Adobe After Effects 23.6.9, 24.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39380 or the next vulnerability affects your stack