What’s Vulnerable › Vulnerabilities
CVE-2024-3939: Ditty < 3.1.36 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ditty WordPress plugin before 3.1.36 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Ditty: before 3.1.36 — fixed in 3.1.36
How to fix
Upgrade to a fixed version: Ditty 3.1.36. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/80a9eb3a-2cb1-4844-9004-ba2554b2d46c/
- https://wpscan.com/vulnerability/80a9eb3a-2cb1-4844-9004-ba2554b2d46c/
Get alerted when CVE-2024-3939 or the next vulnerability affects your stack