What’s Vulnerable › Vulnerabilities
CVE-2024-39393: Adobe Indesign 2024 PCT File Parsing Memory Corruption Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-14 · updated 2026-06-17
- Weakness: CWE-125
Description
InDesign Desktop versions ID19.4, ID18.5.2 and earlier are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to execute code in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe InDesign Desktop: before 18.5.3; from 19.0 before 19.5 — fixed in 18.5.3, 19.5
How to fix
Upgrade to a fixed version: Adobe InDesign Desktop 18.5.3, 19.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39393 or the next vulnerability affects your stack