What’s Vulnerable › Vulnerabilities
CVE-2024-39425: Security vulnerability in AdobeARMHelper
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-14 · updated 2026-06-17
- Weakness: CWE-367
Description
Acrobat Reader versions 20.005.30636, 24.002.20965, 24.002.20964, 24.001.30123 and earlier are affected by a Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability that could lead to privilege escalation. Exploitation of this issue require local low-privilege access to the affected system and attack complexity is high.
Affected products
- Adobe Acrobat for Edge: from 20.001.30005 before 20.005.30655; from 24.001.20604 before 24.001.30159 — fixed in 20.005.30655, 24.001.30159
- Adobe Acrobat DC: from 15.008.20082 before 24.002.21005 — fixed in 24.002.21005
- Adobe Acrobat Reader: from 20.001.3005 before 20.005.30655 — fixed in 20.005.30655
- Adobe Acrobat Reader: from 15.008.20082 before 24.002.21005 — fixed in 24.002.21005
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30655, 24.001.30159; Adobe Acrobat DC 24.002.21005; Adobe Acrobat Reader 20.005.30655; Adobe Acrobat Reader 24.002.21005. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39425 or the next vulnerability affects your stack