What’s Vulnerable › Vulnerabilities
CVE-2024-39489: ipv6: sr: fix memleak in seg6_hmac_init_algo
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-10-15
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: sr: fix memleak in seg6_hmac_init_algo seg6_hmac_init_algo returns without cleaning up the previous allocations if one fails, so it's going to leak all that memory and the crypto tfms. Update seg6_hmac_exit to only free the memory when allocated, so we can reuse the code directly.
Affected products
- Linux kernel: from 4.10 before 4.19.316; from 4.20 before 5.4.278; from 5.5 before 5.10.219; from 5.11 before 5.15.161; from 5.16 before 6.1.93; from 6.2 before 6.6.33 — fixed in 4.19.316, 5.10.219, 5.15.161, 5.4.278, 6.1.93, 6.6.33
How to fix
Upgrade to a fixed version: Linux kernel 4.19.316, 5.10.219, 5.15.161, 5.4.278. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e44d6cbe8de983470c3d2f978649783384fdcb6
- https://git.kernel.org/stable/c/4a3fcf53725b70010d1cf869a2ba549fed6b8fb3
- https://git.kernel.org/stable/c/599a5654215092ac22bfc453f4fd3959c55ea821
- https://git.kernel.org/stable/c/61d31ac85b4572d11f8071855c0ccb4f32d76c0c
- https://git.kernel.org/stable/c/afd5730969aec960a2fee4e5ee839a6014643976
- https://git.kernel.org/stable/c/daf341e0a2318b813427d5a78788c86f4a7f02be
- https://git.kernel.org/stable/c/efb9f4f19f8e37fde43dfecebc80292d179f56c6
- https://git.kernel.org/stable/c/f6a99ef4e056c20a138a95cc51332b2b96c8f383
- https://git.kernel.org/stable/c/0e44d6cbe8de983470c3d2f978649783384fdcb6
- https://git.kernel.org/stable/c/4a3fcf53725b70010d1cf869a2ba549fed6b8fb3
- https://git.kernel.org/stable/c/599a5654215092ac22bfc453f4fd3959c55ea821
- https://git.kernel.org/stable/c/61d31ac85b4572d11f8071855c0ccb4f32d76c0c
Get alerted when CVE-2024-39489 or the next vulnerability affects your stack