What’s Vulnerable › Vulnerabilities
CVE-2024-39494: ima: Fix use-after-free on a dentry's dname.name
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ima: Fix use-after-free on a dentry's dname.name ->d_name.name can change on rename and the earlier value can be freed; there are conditions sufficient to stabilize it (->d_lock on dentry, ->d_lock on its parent, ->i_rwsem exclusive on the parent's inode, rename_lock), but none of those are met at any of the sites. Take a stable snapshot of the name instead.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 3.19 before 5.4.291; from 5.5 before 5.10.235; from 5.11 before 5.15.174; from 5.16 before 6.1.97; from 6.2 before 6.6.35; from 6.7 before 6.9.6 — fixed in 5.10.235, 5.15.174, 5.4.291, 6.1.97, 6.6.35, 6.9.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.174, 5.4.291, 6.1.97. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b31e28fbd773aefb6164687e0767319b8199829
- https://git.kernel.org/stable/c/480afcbeb7aaaa22677d3dd48ec590b441eaac1a
- https://git.kernel.org/stable/c/7fb374981e31c193b1152ed8d3b0a95b671330d4
- https://git.kernel.org/stable/c/a78a6f0da57d058e2009e9958fdcef66f165208c
- https://git.kernel.org/stable/c/be84f32bb2c981ca670922e047cdde1488b233de
- https://git.kernel.org/stable/c/dd431c3ac1fc34a9268580dd59ad3e3c76b32a8c
- https://git.kernel.org/stable/c/edf287bc610b18d7a9c0c0c1cb2e97b9348c71bb
- https://git.kernel.org/stable/c/7fb374981e31c193b1152ed8d3b0a95b671330d4
- https://git.kernel.org/stable/c/a78a6f0da57d058e2009e9958fdcef66f165208c
- https://git.kernel.org/stable/c/be84f32bb2c981ca670922e047cdde1488b233de
- https://git.kernel.org/stable/c/dd431c3ac1fc34a9268580dd59ad3e3c76b32a8c
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-39494 or the next vulnerability affects your stack