What’s Vulnerable › Vulnerabilities
CVE-2024-39504: netfilter: nft_inner: validate mandatory meta and payload
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: nft_inner: validate mandatory meta and payload Check for mandatory netlink attributes in payload and meta expression when used embedded from the inner expression, otherwise NULL pointer dereference is possible from userspace.
Affected products
- Linux kernel: from 6.2 before 6.6.35; from 6.7 before 6.9.6; 6.10-rc1, 6.10-rc2, 6.10-rc3 — fixed in 6.6.35, 6.9.6
How to fix
Upgrade to a fixed version: Linux kernel 6.6.35, 6.9.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/39323f54cad29602917848346c71b087da92a19d
- https://git.kernel.org/stable/c/b30669fdea0ca03aa22995e6c99f7e7d9dee89ff
- https://git.kernel.org/stable/c/c4ab9da85b9df3692f861512fe6c9812f38b7471
- https://git.kernel.org/stable/c/39323f54cad29602917848346c71b087da92a19d
- https://git.kernel.org/stable/c/b30669fdea0ca03aa22995e6c99f7e7d9dee89ff
- https://git.kernel.org/stable/c/c4ab9da85b9df3692f861512fe6c9812f38b7471
Get alerted when CVE-2024-39504 or the next vulnerability affects your stack