What’s Vulnerable › Vulnerabilities
CVE-2024-39517: Junos OS and Junos OS Evolved: Upon processing specific L2 traffic, rpd can hang in devices with EVPN/VXLAN configured
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-754
Description
An Improper Check for Unusual or Exceptional Conditions vulnerability in the Layer 2 Address Learning Daemon (l2ald) on Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, adjacent attacker to cause Denial of Service (DoS). In an EVPN/VXLAN scenario, when a high amount specific Layer 2 packets are processed by the device, it can cause the Routing Protocol Daemon (rpd) to utilize all CPU resources which causes the device to hang. A manual restart of the rpd is required to restore services. This issue affects both IPv4 and IPv6 implementations. This issue affects Junos OS: All versions earlier than 21.4R3-S7; 22.1 versions earlier than 22.1R3-S5; 22.2 versions earlier than 22.2R3-S3; 22.3 versions earlier than 22.3R3-S3; 22.4 versions earlier than 22.4R3-S2; 23.2 versions earlier than 23.2R2; 23.4 versions earlier than 23.4R1-S1. Junos OS Evolved: All versions earlier than 21.4R3-S7-EVO; 22.1-EVO versions earlier than 22.1R3-S5-EVO; 22.2-EVO versions earlier than 22.2R3-S3-EVO; 22.3-EVO versions earlier than 22.3R3-S3-EVO; 22.4-EVO versions earlier than 22.4R3-S2-EVO; 23.2-EVO versions earlier than 23.2R2-EVO; 23.4-EVO versions earlier than 23.4R1-S1-EVO, 23.4R2-EVO.
Affected products
- Juniper Junos OS: before 21.4; 21.4, 21.4-r1, 21.4-r1-s1, 21.4-r1-s2, 21.4-r2, 21.4-r2-s1 (+55) — fixed in 21.4
- Juniper Networks Junos OS Evolved: before 21.4; 21.4, 21.4-r1, 21.4-r1-s1, 21.4-r1-s2, 21.4-r2, 21.4-r2-s1 (+54) — fixed in 21.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 21.4; Juniper Networks Junos OS Evolved 21.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39517 or the next vulnerability affects your stack