What’s Vulnerable › Vulnerabilities
CVE-2024-39573: Apache HTTP Server: mod_rewrite proxy handler substitution
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 35.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-01 · updated 2026-06-17
- Weakness: CWE-20
Description
Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.60 — fixed in 2.4.60
- NetApp ONTAP 9: 9
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.60. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.netapp.com/advisory/ntap-20240712-0001/
- http://seclists.org/fulldisclosure/2024/Oct/11
- http://www.openwall.com/lists/oss-security/2024/07/01/11
- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.netapp.com/advisory/ntap-20240712-0001/
Get alerted when CVE-2024-39573 or the next vulnerability affects your stack