What’s Vulnerable › Vulnerabilities
CVE-2024-39577
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Dell SmartFabric OS10 Software, versions 10.5.6.x, 10.5.5.x, 10.5.4.x, 10.5.3.x, contains an Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability leading to code execution.
Affected products
- Dell SmartFabric OS10 Software: from 10.5.3.0 before 10.5.3.11; from 10.5.4.0 before 10.5.4.12; from 10.5.5.0 before 10.5.5.11; from 10.5.6.0 before 10.5.6.4 — fixed in 10.5.3.11, 10.5.4.12, 10.5.5.11, 10.5.6.4
How to fix
Upgrade to a fixed version: Dell SmartFabric OS10 Software 10.5.3.11, 10.5.4.12, 10.5.5.11, 10.5.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39577 or the next vulnerability affects your stack