What’s Vulnerable › Vulnerabilities
CVE-2024-39614
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-130
Description
An issue was discovered in Django 5.0 before 5.0.7 and 4.2 before 4.2.14. get_supported_language_variant() was subject to a potential denial-of-service attack when used with very long strings containing specific characters.
Affected products
- Django: from 4.2 before 4.2.14; from 5.0 before 5.0.7 — fixed in 4.2.14, 5.0.7
How to fix
Upgrade to a fixed version: Django 4.2.14, 5.0.7. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/jul/09/security-releases/
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://security.netapp.com/advisory/ntap-20240808-0005/
- https://www.djangoproject.com/weblog/2024/jul/09/security-releases/
Get alerted when CVE-2024-39614 or the next vulnerability affects your stack