What’s Vulnerable › Vulnerabilities
CVE-2024-3962: Product Addons & Fields for WooCommerce <= 32.0.18 - Unauthenticated Arbitrary File Upload via ppom_upload_file
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-434
Description
The Product Addons & Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ppom_upload_file function in all versions up to, and including, 32.0.18. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Successful exploitation requires the PPOM Pro plugin to be installed along with a WooCommerce product that contains a file upload field to retrieve the correct nonce.
Affected products
- themeisle PPOM – Product Addons & Custom Fields for WooCommerce: before 32.0.19 — fixed in 32.0.19
How to fix
Upgrade to a fixed version: themeisle PPOM – Product Addons & Custom Fields for WooCommerce 32.0.19. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3075669/woocommerce-product-addon
- https://themeisle.com/plugins/ppom-pro/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4f95bcc3-354e-4016-9a17-945569b076b6?source=cve
- https://plugins.trac.wordpress.org/changeset/3075669/woocommerce-product-addon
- https://themeisle.com/plugins/ppom-pro/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4f95bcc3-354e-4016-9a17-945569b076b6?source=cve
Get alerted when CVE-2024-3962 or the next vulnerability affects your stack