What’s Vulnerable › Vulnerabilities
CVE-2024-39628: WordPress Ninja Forms plugin <= 3.8.6 - Cross Site Request Forgery (CSRF) vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Saturday Drive Ninja Forms allows Cross Site Request Forgery.This issue affects Ninja Forms: from n/a through 3.8.6.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.8.7 — fixed in 3.8.7
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.8.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39628 or the next vulnerability affects your stack