What’s Vulnerable › Vulnerabilities
CVE-2024-39638: WordPress Registrations for the Events Calendar plugin <= 2.12.2 - SQL Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Roundup WP Registrations for the Events Calendar allows SQL Injection.This issue affects Registrations for the Events Calendar: from n/a through 2.12.2.
Affected products
- Registrations for the Events Calendar – Event Registration Plugin: before 2.12.3 — fixed in 2.12.3
How to fix
Upgrade to a fixed version: Registrations for the Events Calendar – Event Registration Plugin 2.12.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39638 or the next vulnerability affects your stack