What’s Vulnerable › Vulnerabilities
CVE-2024-3964: Product Enquiry for WooCommerce < 3.1.8 - Admin+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Product Enquiry for WooCommerce WordPress plugin before 3.1.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WisdmLabs Product Enquiry For Woocommerce: before 3.1.8 — fixed in 3.1.8
How to fix
Upgrade to a fixed version: WisdmLabs Product Enquiry For Woocommerce 3.1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ff468772-3e6a-439c-a4d7-94bd2ce1a964/
- https://wpscan.com/vulnerability/ff468772-3e6a-439c-a4d7-94bd2ce1a964/
Get alerted when CVE-2024-3964 or the next vulnerability affects your stack