What’s Vulnerable › Vulnerabilities
CVE-2024-39643: WordPress RegistrationMagic plugin <= 6.0.0.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in RegistrationMagic Forms RegistrationMagic allows Stored XSS.This issue affects RegistrationMagic: from n/a through 6.0.0.1.
Affected products
- Metagauss RegistrationMagic: before 6.0.0.2 — fixed in 6.0.0.2
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 6.0.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39643 or the next vulnerability affects your stack