What’s Vulnerable › Vulnerabilities
CVE-2024-39646: WordPress Custom 404 Pro plugin <= 3.11.1 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kunal Custom 404 Pro custom-404-pro.This issue affects Custom 404 Pro: from n/a through <= 3.11.1.
Affected products
- Kunal Nagar Custom 404 Pro: before 3.11.2 — fixed in 3.11.2
How to fix
Upgrade to a fixed version: Kunal Nagar Custom 404 Pro 3.11.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39646 or the next vulnerability affects your stack