What’s Vulnerable › Vulnerabilities
CVE-2024-39647: WordPress Message Filter for Contact Form 7 plugin <= 1.6.1.1 - Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kofi Mokome Message Filter for Contact Form 7 cf7-message-filter.This issue affects Message Filter for Contact Form 7: from n/a through <= 1.6.1.1.
Affected products
- Kofi Mokome Message Filter for Contact Form 7: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Kofi Mokome Message Filter for Contact Form 7 1.6.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39647 or the next vulnerability affects your stack