What’s Vulnerable › Vulnerabilities
CVE-2024-39651: WordPress WooCommerce PDF Vouchers plugin < 4.9.5 - Unauthenticated Arbitrary File Deletion vulnerability
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in WPWeb WooCommerce PDF Vouchers allows File Manipulation.This issue affects WooCommerce PDF Vouchers: from n/a before 4.9.5.
Affected products
- wpweb WooCommerce PDF Vouchers: before 4.9.5 — fixed in 4.9.5
How to fix
Upgrade to a fixed version: wpweb WooCommerce PDF Vouchers 4.9.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39651 or the next vulnerability affects your stack