What’s Vulnerable › Vulnerabilities
CVE-2024-39682: WordPress Cooked Plugin - Authenticated (Contributor+) HTML Injection via Recipe Excerpt
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-116
Description
Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to HTML Injection in versions up to, and including, 1.7.15.4 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with contributor-level access and above to inject arbitrary HTML in pages that will be shown whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- XjSv Cooked: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: XjSv Cooked 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/XjSv/Cooked/security/advisories/GHSA-fx69-f77x-84gr
- https://github.com/XjSv/Cooked/security/advisories/GHSA-fx69-f77x-84gr
Get alerted when CVE-2024-39682 or the next vulnerability affects your stack