What’s Vulnerable › Vulnerabilities
CVE-2024-39693: Next.js Denial of Service (DoS) condition
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-10 · updated 2026-06-17
- Weakness: CWE-400
Description
Next.js is a React framework. A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server. his vulnerability was resolved in Next.js 13.5 and later.
Affected products
- Next.js: from 13.3.1 before 13.5.0 — fixed in 13.5.0
- Npm Next: from 13.3.1 before 13.5.0 — fixed in 13.5.0
How to fix
Upgrade to a fixed version: Next.js 13.5.0; Npm Next 13.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/security/advisories/GHSA-fq54-2j52-jc42
- https://github.com/vercel/next.js/security/advisories/GHSA-fq54-2j52-jc42
Get alerted when CVE-2024-39693 or the next vulnerability affects your stack