What’s Vulnerable › Vulnerabilities
CVE-2024-39700: Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-94
Description
JupyterLab extension template is a `copier` template for JupyterLab extensions. Repositories created using this template with `test` option include `update-integration-tests.yml` workflow which has an RCE vulnerability. Extension authors hosting their code on GitHub are urged to upgrade the template to the latest version. Users who made changes to `update-integration-tests.yml`, accept overwriting of this file and re-apply your changes later. Users may wish to temporarily disable GitHub Actions while working on the upgrade. We recommend rebasing all open pull requests from untrusted users as actions may run using the version from the `main` branch at the time when the pull request was created. Users who are upgrading from template version prior to 4.3.0 may wish to leave out proposed changes to the release workflow for now as it requires additional configuration.
Affected products
- jupyterlab: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: jupyterlab 4.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/jupyterlab/extension-template/commit/035e78c1c65bcedee97c95bb683abe59c96bc4e6
- https://github.com/jupyterlab/extension-template/security/advisories/GHSA-45gq-v5wm-82wg
- https://github.com/jupyterlab/extension-template/commit/035e78c1c65bcedee97c95bb683abe59c96bc4e6
- https://github.com/jupyterlab/extension-template/security/advisories/GHSA-45gq-v5wm-82wg
Get alerted when CVE-2024-39700 or the next vulnerability affects your stack