What’s Vulnerable › Vulnerabilities
CVE-2024-39701: Directus Incorrectly handles _in` filter
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-284
Description
Directus is a real-time API and App dashboard for managing SQL database content. Directus >=9.23.0, <=v10.5.3 improperly handles _in, _nin operators. It evaluates empty arrays as valid so expressions like {"role": {"_in": $CURRENT_USER.some_field}} would evaluate to true allowing the request to pass. This results in Broken Access Control because the rule fails to do what it was intended to do: Pass rule if **field** matches any of the **values**. This vulnerability is fixed in 10.6.0.
Affected products
- directus: from 9.23.0 before 10.6.0 — fixed in 10.6.0
How to fix
Upgrade to a fixed version: directus 10.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/directus/directus/security/advisories/GHSA-hxgm-ghmv-xjjm
- https://github.com/directus/directus/security/advisories/GHSA-hxgm-ghmv-xjjm
Get alerted when CVE-2024-39701 or the next vulnerability affects your stack