What’s Vulnerable › Vulnerabilities
CVE-2024-39709
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-13 · updated 2026-06-17
- Weakness: CWE-732
Description
Incorrect file permissions in Ivanti Connect Secure before version 22.6R2 (Not Applicable to 9.1Rx) and Ivanti Policy Secure before version 22.7R1 (Not Applicable to 9.1Rx) allow a local authenticated attacker to escalate their privileges.
Affected products
- Ivanti Connect Secure (Pulse Secure): before 9.1; from 21.9 before 22.6; 9.1, 22.6, 22.6-r1 — fixed in 22.6, 9.1
- Ivanti Policy Secure: before 9.1; from 22.1 before 22.7; 9.1, 22.7 — fixed in 22.7, 9.1
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 22.6, 9.1; Ivanti Policy Secure 22.7, 9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39709 or the next vulnerability affects your stack