What’s Vulnerable › Vulnerabilities
CVE-2024-39722
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-31 · updated 2026-06-17
- Weakness: CWE-22
Description
An issue was discovered in Ollama before 0.1.46. It exposes which files exist on the server on which it is deployed via path traversal in the api/push route.
Affected products
- Ollama: before 0.1.46 — fixed in 0.1.46
How to fix
Upgrade to a fixed version: Ollama 0.1.46. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39722 or the next vulnerability affects your stack