What’s Vulnerable › Vulnerabilities
CVE-2024-39742: IBM MQ Container authentication bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-08 · updated 2026-06-17
- Weakness: CWE-187
Description
IBM MQ Operator 3.2.2 and IBM MQ Operator 2.0.24 could allow a user to bypass authentication under certain configurations due to a partial string comparison vulnerability. IBM X-Force ID: 297169.
Affected products
- IBM MQ Operator: from 2.0.0 before 2.0.24; from 2.2.0 through 2.2.2; from 2.3.0 through 2.3.3; from 2.4.0 through 2.4.8; from 3.1.0 through 3.1.3; from 3.2.0 before 3.2.2 — fixed in 2.0.24, 3.2.2
How to fix
Upgrade to a fixed version: IBM MQ Operator 2.0.24, 3.2.2. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/297169
- https://www.ibm.com/support/pages/node/7159714
- https://exchange.xforce.ibmcloud.com/vulnerabilities/297169
- https://www.ibm.com/support/pages/node/7159714
Get alerted when CVE-2024-39742 or the next vulnerability affects your stack