What’s Vulnerable › Vulnerabilities
CVE-2024-39750: IBM Analytics Content Hub buffer overflow
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-120
Description
IBM Analytics Content Hub 2.0 is vulnerable to a buffer overflow due to improper return length checking. A remote authenticated attacker could overflow a buffer and execute arbitrary code on the system or cause the server to crash.
Affected products
- IBM Analytics Content Hub: from 2.0 before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: IBM Analytics Content Hub 2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-39750 or the next vulnerability affects your stack