What’s Vulnerable › Vulnerabilities
CVE-2024-39840
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-29 · updated 2026-06-17
- Weakness: CWE-787
Description
Factorio before 1.1.101 allows a crafted server to execute arbitrary code on clients via a custom map that leverages the ability of certain Lua base module functions to execute bytecode and generate fake objects.
Affected products
- Factorio: before 1.1.101 — fixed in 1.1.101
How to fix
Upgrade to a fixed version: Factorio 1.1.101. Check the vendor advisory for mitigations.
References
- https://memorycorruption.net/posts/rce-lua-factorio/
- https://news.ycombinator.com/item?id=40830005
- https://memorycorruption.net/posts/rce-lua-factorio/
- https://news.ycombinator.com/item?id=40830005
Get alerted when CVE-2024-39840 or the next vulnerability affects your stack