What’s Vulnerable › Vulnerabilities
CVE-2024-39863: Apache Airflow: Potential XSS Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.
Affected products
- Apache Airflow: before 2.9.3 — fixed in 2.9.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/40475
- https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3
- http://www.openwall.com/lists/oss-security/2024/07/16/6
- https://github.com/apache/airflow/pull/40475
- https://lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3
Get alerted when CVE-2024-39863 or the next vulnerability affects your stack