What’s Vulnerable › Vulnerabilities
CVE-2024-39887: Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-89
Description
An SQL Injection vulnerability in Apache Superset exists due to improper neutralization of special elements used in SQL commands. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. To mitigate this, a new configuration key named DISALLOWED_SQL_FUNCTIONS has been introduced. This key disallows the use of the following PostgreSQL functions: version, query_to_xml, inet_server_addr, and inet_client_addr. Additional functions can be added to this list for increased protection. This issue affects Apache Superset: before 4.0.2. Users are recommended to upgrade to version 4.0.2, which fixes the issue.
Affected products
- Apache Superset: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: Apache Superset 4.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/07/16/5
- https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz
- http://www.openwall.com/lists/oss-security/2024/07/16/5
- https://lists.apache.org/thread/j55vm41jg3l0x6w49zrmvbf3k0ts5fqz
Get alerted when CVE-2024-39887 or the next vulnerability affects your stack