What’s Vulnerable › Vulnerabilities
CVE-2024-39891: Twilio Authy Information Disclosure Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-07-23
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-02 · updated 2026-06-17
- Weakness: CWE-203
Description
In the Twilio Authy API, accessed by Authy Android before 25.1.0 and Authy iOS before 26.1.0, an unauthenticated endpoint provided access to certain phone-number data, as exploited in the wild in June 2024. Specifically, the endpoint accepted a stream of requests containing phone numbers, and responded with information about whether each phone number was registered with Authy. (Authy accounts were not compromised, however.)
Affected products
- Twilio Authy: before 26.1.0 — fixed in 26.1.0
- Twilio Authy Authenticator: before 25.1.0 — fixed in 25.1.0
How to fix
Upgrade to a fixed version: Twilio Authy 26.1.0; Twilio Authy Authenticator 25.1.0. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/203.html
- https://www.bleepingcomputer.com/news/security/hackers-abused-api-to-verify-millions-of-authy-mfa-phone-numbers/
- https://www.twilio.com/docs/usage/security/reporting-vulnerabilities
- https://www.twilio.com/en-us/changelog
- https://cwe.mitre.org/data/definitions/203.html
- https://www.bleepingcomputer.com/news/security/hackers-abused-api-to-verify-millions-of-authy-mfa-phone-numbers/
- https://www.twilio.com/docs/usage/security/reporting-vulnerabilities
- https://www.twilio.com/en-us/changelog
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-39891
Get alerted when CVE-2024-39891 or the next vulnerability affects your stack