What’s Vulnerable › Vulnerabilities
CVE-2024-39902: Tuleap's recursive permissions to document manager folder are not properly applied
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-281
Description
Tuleap is an open source suite to improve management of software developments and collaboration. Prior to Tuleap Community Edition 15.10.99.128 and Tuleap Enterprise Edition 15.10-6 and 15.9-8, the checkbox "Apply same permissions to all sub-items of this folder" in the document manager permissions modal is not taken into account and always considered as unchecked. In situations where the permissions are being restricted some users might still keep, incorrectly, the possibility to edit or manage items. Only change made via the web UI are affected, changes directly made via the REST API are not impacted. This vulnerability is fixed in Tuleap Community Edition 15.10.99.128 and Tuleap Enterprise Edition 15.10-6 and 15.9-8.
Affected products
- Enalean tuleap: before 15.9-8; before 15.10.99.128; from 15.10 before 15.10-6 — fixed in 15.10-6, 15.10.99.128, 15.9-8
How to fix
Upgrade to a fixed version: Enalean tuleap 15.10-6, 15.10.99.128, 15.9-8. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/580161e8a065fba30ca5ca1f6f1bdb4f4b1424bb
- https://github.com/Enalean/tuleap/security/advisories/GHSA-5jq5-vxmq-xrj7
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=580161e8a065fba30ca5ca1f6f1bdb4f4b1424bb
- https://tuleap.net/plugins/tracker/?aid=38675
- https://github.com/Enalean/tuleap/commit/580161e8a065fba30ca5ca1f6f1bdb4f4b1424bb
- https://github.com/Enalean/tuleap/security/advisories/GHSA-5jq5-vxmq-xrj7
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=580161e8a065fba30ca5ca1f6f1bdb4f4b1424bb
- https://tuleap.net/plugins/tracker/?aid=38675
Get alerted when CVE-2024-39902 or the next vulnerability affects your stack