What’s Vulnerable › Vulnerabilities
CVE-2024-39905: Red-DiscordBot vulnerable to Incorrect Authorization in commands API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-863
Description
Red is a fully modular Discord bot. Due to a bug in Red's Core API, 3rd-party cogs using the `@commands.can_manage_channel()` command permission check without additional permission controls may authorize a user to run a command even when that user doesn't have permissions to manage a channel. None of the core commands or core cogs are affected. The maintainers of the project are not aware of any _public_ 3rd-party cog utilizing this API at the time of writing this advisory. The problem was patched and released in version 3.5.10.
Affected products
- Cog-Creators Red-DiscordBot: from 3.5.0 before 3.5.10 — fixed in 3.5.10
How to fix
Upgrade to a fixed version: Cog-Creators Red-DiscordBot 3.5.10. Check the vendor advisory for mitigations.
References
- https://github.com/Cog-Creators/Red-DiscordBot/commit/0b0b23b9717b40ed4f8715720b199417c8e89750
- https://github.com/Cog-Creators/Red-DiscordBot/pull/6398
- https://github.com/Cog-Creators/Red-DiscordBot/security/advisories/GHSA-5jq8-q6rj-9gq4
- https://github.com/Cog-Creators/Red-DiscordBot/commit/0b0b23b9717b40ed4f8715720b199417c8e89750
- https://github.com/Cog-Creators/Red-DiscordBot/pull/6398
- https://github.com/Cog-Creators/Red-DiscordBot/security/advisories/GHSA-5jq8-q6rj-9gq4
Get alerted when CVE-2024-39905 or the next vulnerability affects your stack