What’s Vulnerable › Vulnerabilities
CVE-2024-39907: a sqlinjection in 1Panel
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 29.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-18 · updated 2026-06-17
- Weakness: CWE-89
Description
1Panel is a web-based linux server management control panel. There are many sql injections in the project, and some of them are not well filtered, leading to arbitrary file writes, and ultimately leading to RCEs. These sql injections have been resolved in version 1.10.12-tls. Users are advised to upgrade. There are no known workarounds for these issues.
Affected products
- 1Panel-dev 1Panel: from 1.10.9-lts before 1.10.12-lts — fixed in 1.10.12-lts
How to fix
Upgrade to a fixed version: 1Panel-dev 1Panel 1.10.12-lts. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-5grx-v727-qmq6
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-5grx-v727-qmq6
Get alerted when CVE-2024-39907 or the next vulnerability affects your stack