What’s Vulnerable › Vulnerabilities
CVE-2024-39908: Denial of service in REXML
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-16 · updated 2026-06-17
- Weakness: CWE-400
Description
REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.
Affected products
- NetApp Bootstrap Os: all versions
- ruby rexml: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: ruby rexml 3.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/ruby/rexml/security/advisories/GHSA-4xqq-m2hx-25v8
- https://www.ruby-lang.org/en/news/2024/07/16/dos-rexml-cve-2024-39908
- https://github.com/ruby/rexml/security/advisories/GHSA-4xqq-m2hx-25v8
- https://lists.debian.org/debian-lts-announce/2025/01/msg00011.html
- https://security.netapp.com/advisory/ntap-20250117-0008/
- https://www.ruby-lang.org/en/news/2024/07/16/dos-rexml-cve-2024-39908
Get alerted when CVE-2024-39908 or the next vulnerability affects your stack