What’s Vulnerable › Vulnerabilities
CVE-2024-39910: Cross-site scripting (XSS) in the decidim admin panel with QuillJS WYSWYG editor
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The WYSWYG editor QuillJS is subject to potential XSS attach in case the attacker manages to modify the HTML before being uploaded to the server. The attacker is able to change e.g. to <svg onload=alert('XSS')> if they know how to craft these requests themselves. This issue has been addressed in release version 0.27.7. All users are advised to upgrade. Users unable to upgrade should review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it. Disable the "Enable rich text editor for participants" setting in the admin dashboard
Affected products
- decidim: before 0.27.7 — fixed in 0.27.7
How to fix
Upgrade to a fixed version: decidim 0.27.7. Check the vendor advisory for mitigations.
References
- https://github.com/decidim/decidim/commit/47adca81cabea898005ec07b130b008f2a2be99f
- https://github.com/decidim/decidim/security/advisories/GHSA-vvqw-fqwx-mqmm
Get alerted when CVE-2024-39910 or the next vulnerability affects your stack