What’s Vulnerable › Vulnerabilities
CVE-2024-39935
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-78
Description
jc21 NGINX Proxy Manager before 2.11.3 allows backend/internal/certificate.js OS command injection by an authenticated user (with certificate management privileges) via untrusted input to the DNS provider configuration. NOTE: this is not part of any NGINX software shipped by F5.
Affected products
- Jc21 Nginx Proxy Manager: before 2.11.3 — fixed in 2.11.3
How to fix
Upgrade to a fixed version: Jc21 Nginx Proxy Manager 2.11.3. Check the vendor advisory for mitigations.
References
- https://github.com/NginxProxyManager/nginx-proxy-manager/commit/99cce7e2b0da2978411cedd7cac5fffbe15bc46
- https://github.com/NginxProxyManager/nginx-proxy-manager/compare/v2.11.2...v2.11.3
- https://github.com/NginxProxyManager/nginx-proxy-manager/issues/3662
- https://github.com/NginxProxyManager/nginx-proxy-manager/commit/99cce7e2b0da2978411cedd7cac5fffbe15bc46
- https://github.com/NginxProxyManager/nginx-proxy-manager/compare/v2.11.2...v2.11.3
- https://github.com/NginxProxyManager/nginx-proxy-manager/issues/3662
Get alerted when CVE-2024-39935 or the next vulnerability affects your stack