What’s Vulnerable › Vulnerabilities
CVE-2024-39936
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-04 · updated 2026-06-17
- Weakness: CWE-367
Description
An issue was discovered in HTTP2 in Qt before 5.15.18, 6.x before 6.2.13, 6.3.x through 6.5.x before 6.5.7, and 6.6.x through 6.7.x before 6.7.3. Code to make security-relevant decisions about an established connection may execute too early, because the encrypted() signal has not yet been emitted and processed..
Affected products
- Qt: before 5.15.18; from 6.0.0 before 6.2.13; from 6.3.0 before 6.5.7; from 6.6.0 before 6.7.3 — fixed in 5.15.18, 6.2.13, 6.5.7, 6.7.3
How to fix
Upgrade to a fixed version: Qt 5.15.18, 6.2.13, 6.5.7, 6.7.3. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/qtbase/+/571601
- https://codereview.qt-project.org/c/qt/qtbase/+/571601
- https://lists.debian.org/debian-lts-announce/2025/11/msg00031.html
Get alerted when CVE-2024-39936 or the next vulnerability affects your stack